Want to Join Us ?

you'll be able to discuss, share and send private messages.

Release IDA PRO Prebuild PyQt4-ida-pro_PyQt5-regular python 2.7x86

Discussion in 'Plugins' started by storm shadow, Apr 23, 2015.

Share This Page

  1. storm shadow

    Techbliss Owner Admin Ida Pro Expert Developer

    I always hated that beeing limited to only use PyQt4 for ida , and not have the choice to use PyQt5 for normal use.
    PyQt5 have much extra to offer for developing apps for android etc.
    Riverbank only supply PyQt5 for python 3.4.


    Also there was only a x64 version build for 2.7, when searching on worlwideb.And that was one of the very first PyQt5 version.
    So i had to build all from scratch.


    When ida 6.9 comes out it proberly will switch to PyQt5 only.

    Ida PyQt4 4.9.4 with QT namespace for ida pro.
    and PyQt5 5.3.2 for python x86 for develoment for regular use, so not for ida pro.
    And build for the same sip version.
    first Download
    https://mega.co.nz/#!zwsi2ADb!6jm5zD36Eq71ftQqEa1gp2yKUvMx3ukszZMLBODQtY0



    Everything is allready build, but PyQt5 have alot of sip files.
    extract anywhere and open visual command promt, goto PyQt-gpl-5.3.2 folder and
    run
    Code (Text):
    nmake install


    then DL PyQt4 and PyQt5 package


    https://mega.nz/#!PtUFwQ4T!BR_Aw1jrhNzO6oQrq2Fg803ggtbj94ekOlEOBLApYNY
    pass techbliss


    and extract everything to folder

    C:\Python27\Lib\site-packages

    If trouble, you proberly havent setting your enviroment right see this mini tut howto do that.

    http://www.techbliss.org/threads/adb-qt-super-version.626/#post-2095


    UPDATE!! 30.06.2015

    NEW BUILD.
    PyQt-win-gpl-4.11.4

    https://mega.nz/#!roUQjbLR!VgV9IE7QhnvpWUlPakL8DxfjZMu06w-RmFwE4bklZ4I


    Extract to right folder
    and sip 4.16.4
    https://mega.nz/#!K100SAZb!hrg_1MsIJoojrP6c8vfvSWaaqiBbyjcjFhHmuJ43N9U

    extract sip package goto folder, and do

    Code (Text):
    nmake install
    (Do not reconfigure)

    PyQT5 still works with this sip version. ;)

    Also hexrays version is incomplete.
    this have qsciscintilla , webkit. and more , qsciscintilla shows in the designer also, i added the qsciscintilla designer plugin so you can try it from PyQt4 designer, and added music backends.



    use this
    http://www.techbliss.org/threads/py...-total-package-installer-by-storm-shadow.768/


     
    Last edited: Jul 26, 2016
    computerline and Rip Cord like this.
  2. storm shadow

    Techbliss Owner Admin Ida Pro Expert Developer

    Accezz likes this.
  3. storm shadow

    Techbliss Owner Admin Ida Pro Expert Developer

    UPDATE!! 30.06.2015


    NEW BUILD.
    PyQt-win-gpl-4.11.4
    https://mega.nz/#!roUQjbLR!VgV9IE7QhnvpWUlPakL8DxfjZMu06w-RmFwE4bklZ4I


    Extract to right folder
    and sip 4.16.4
    https://mega.nz/#!K100SAZb!hrg_1MsIJoojrP6c8vfvSWaaqiBbyjcjFhHmuJ43N9U


    extract sip package goto folder, and do
    Code (Text):
    nmake install
    (Do not reconfigure)


    PyQT5 still works with this sip version.


    Also hexrays version is incomplete.
    this have qsciscintilla , webkit. and more , qsciscintilla shows in the designer also, i added the qsciscintilla designer plugin so you can try it from PyQt4 designer, and added music backends.
     
    Last edited: Sep 10, 2015
    Rip Cord and computerline like this.
  4. m4n0w4r

    Well-Known Member

    @ storm shadow: All links (UPDATE!! 30.06.2015) are dead! Can you re-uploade, plz,

    Regards,
     
  5. storm shadow

    Techbliss Owner Admin Ida Pro Expert Developer

    Rip Cord and m4n0w4r like this.
  6. storm shadow

    Techbliss Owner Admin Ida Pro Expert Developer

    All links updatet , but always use links in the last post since sip and PyQt goes together
     
  7. m4n0w4r

    Well-Known Member

    storm shadow likes this.
  8. storm shadow

    Techbliss Owner Admin Ida Pro Expert Developer

Top